summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-15 22:08:50 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-21 16:23:58 +0200
commit66d4d23a0db21eccd59a23684b4b680ddb8ccd55 (patch)
treeddc13222ff95697649286e958d9eb3347504f60f
parent7353994bad8c0b9eff31e36e612dc8951c832839 (diff)
downloadpatches-66d4d23a0db21eccd59a23684b4b680ddb8ccd55.tar
patches-66d4d23a0db21eccd59a23684b4b680ddb8ccd55.tar.gz
gnu: Add rust-tokio-core-0.1.
* gnu/packages/crates-io.scm (rust-tokio-core-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 738d8aecf7..9a72a5ca9a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11543,6 +11543,54 @@ backed applications.")
"Utilities for encoding and decoding frames.")
(license license:expat)))
+(define-public rust-tokio-core-0.1
+ (package
+ (name "rust-tokio-core")
+ (version "0.1.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tokio-core" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wbgg59mxfvrhzv97y56nh3gmnmw3jj9dhgkmvz27410jjxzpvxf"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.4)
+ ("rust-futures" ,rust-futures-0.1)
+ ("rust-iovec" ,rust-iovec-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-mio" ,rust-mio-0.6)
+ ("rust-scoped-tls" ,rust-scoped-tls-0.1)
+ ("rust-tokio" ,rust-tokio-0.1)
+ ("rust-tokio-executor" ,rust-tokio-executor-0.1)
+ ("rust-tokio-io" ,rust-tokio-io-0.1)
+ ("rust-tokio-reactor" ,rust-tokio-reactor-0.1)
+ ("rust-tokio-timer" ,rust-tokio-timer-0.2))
+ #:cargo-development-inputs
+ (("rust-env-logger" ,rust-env-logger-0.4)
+ ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-futures-cpupool" ,rust-futures-cpupool-0.1)
+ ("rust-http" ,rust-http-0.1)
+ ("rust-httparse" ,rust-httparse-1.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-num-cpus" ,rust-num-cpus-1.10)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-time" ,rust-time-0.1))))
+ (home-page "https://tokio.rs")
+ (synopsis
+ "Core I/O and event loop primitives for asynchronous I/O in Rust")
+ (description
+ "Core I/O and event loop primitives for asynchronous I/O in Rust.
+Foundation for the rest of the tokio crates.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-tokio-current-thread-0.1
(package
(name "rust-tokio-current-thread")