summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-15 20:08:32 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-21 16:23:55 +0200
commit5e5ca33cd9112584032225675d073e6175015c0b (patch)
tree054de80f95d6a66ca4428b7a8dd6db07a31a7719
parentc0e73f92ba4c0dc0218317a4346a2eda4a87d5f8 (diff)
downloadpatches-5e5ca33cd9112584032225675d073e6175015c0b.tar
patches-5e5ca33cd9112584032225675d073e6175015c0b.tar.gz
gnu: Add rust-hashbrown-0.5.
* gnu/packages/crates-io.scm (rust-hashbrown-0.5): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1d44cb86f6..3e3082824d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4425,6 +4425,40 @@ IEEE 754-2008 binary16 type.")
the template engine that renders the official Rust website")
(license license:expat)))
+(define-public rust-hashbrown-0.5
+ (package
+ (name "rust-hashbrown")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hashbrown" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lr3gsicplw7czapsscmii87hgzpvxf5ch92v7pi95xsipxl3pp1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+ ("rust-rayon" ,rust-rayon-1.1)
+ ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1.0)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1.0)
+ ("rust-serde" ,rust-serde-1.0))
+ #:cargo-development-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-rand" ,rust-rand-0.5)
+ ("rust-rayon" ,rust-rayon-1.1)
+ ("rust-rustc-hash" ,rust-rustc-hash-1.0)
+ ("rust-serde-test" ,rust-serde-test-1.0))))
+ (home-page "https://github.com/rust-lang/hashbrown")
+ (synopsis "Rust port of Google's SwissTable hash map")
+ (description
+ "This package provides a Rust port of Google's SwissTable hash map.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-heapsize-0.4
(package
(name "rust-heapsize")