summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-19 20:23:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 21:53:51 +0100
commit544ea9c2df82bd737319b29a0e4f9b2f39c6321a (patch)
tree11f990ea9aed8917a69f8a01e2b332b56bc44c61
parent20bf58bff470bfacb16cb5c1fd731c707f8dd077 (diff)
downloadpatches-544ea9c2df82bd737319b29a0e4f9b2f39c6321a.tar
patches-544ea9c2df82bd737319b29a0e4f9b2f39c6321a.tar.gz
gnu: Add python-anytree.
* gnu/packages/python-xyz.scm (python-anytree): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dce1dddfba..715a0109f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2584,6 +2584,30 @@ important tasks for becoming a daemon process:
;; Only setup.py is gpl3+, everything else is apache 2.0 licensed.
(license (list license:asl2.0 license:gpl3+))))
+(define-public python-anytree
+ (package
+ (name "python-anytree")
+ (version "2.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "anytree" version))
+ (sha256
+ (base32
+ "1aycpc387wqz7h9w2p53qxn43qsh3m6by6ak4kkc66x9aprr63rz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (native-inputs
+ `(;; For tests.
+ ("graphviz" ,graphviz) ;for 'dot'
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/c0fec0de/anytree")
+ (synopsis "Lightweight tree data library")
+ (description
+ "@code{anytree} is a simple, lightweight, and extensible tree data
+structure for Python.")
+ (license license:asl2.0)))
+
(define-public python-docutils
(package
(name "python-docutils")