summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-21 00:16:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-21 01:11:39 +0100
commit2624921a64727d137505c6f104692d2b88845a98 (patch)
treecf7e5ea9ff01bbf6d10585710a615c3df760c6e4
parent2e038f36f80246ef623e22921baf3731f113a124 (diff)
downloadpatches-2624921a64727d137505c6f104692d2b88845a98.tar
patches-2624921a64727d137505c6f104692d2b88845a98.tar.gz
gnu: Add ocaml-mmap.
* gnu/packages/ocaml.scm (ocaml-mmap): New variable.
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 37214bba94..7e71f7627f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1739,6 +1739,26 @@ lets the client choose the concrete timeline.")
through Transport Layer Security (@dfn{TLS}) encrypted connections.")
(license license:lgpl2.1)))
+(define-public ocaml-mmap
+ (package
+ (name "ocaml-mmap")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/mmap")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1jaismy5d1bhbbanysmr2k79px0yv6ya265dri3949nha1l23i60"))))
+ (build-system dune-build-system)
+ (home-page "https://github.com/mirage/mmap")
+ (synopsis "File mapping for OCaml")
+ (description "This project provides a @command{Mmap.map_file} function
+for mapping files in memory. This function is the same as the
+@command{Unix.map_file} funciton added in OCaml >= 4.06.")
+ (license (list license:qpl license:lgpl2.0))))
+
(define-public ocaml-lwt
(package
(name "ocaml-lwt")