summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-20 20:32:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 00:43:24 +0100
commit21e733ce4eb5f15d195d129d659d1be373696a9c (patch)
tree6f8cd27cc07f9570e0d023f9fc13a1d37d8f400b
parentfa730a9780475846b038cb99b1dc47fd43c67e1c (diff)
downloadpatches-21e733ce4eb5f15d195d129d659d1be373696a9c.tar
patches-21e733ce4eb5f15d195d129d659d1be373696a9c.tar.gz
gnu: supercollider: Update to 3.10.4.
* gnu/packages/audio.scm (supercollider): Update to 3.10.4. [source]: Remove patch. * gnu/packages/patches/supercollider-boost-1.70-build-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/audio.scm11
-rw-r--r--gnu/packages/patches/supercollider-boost-1.70-build-fix.patch28
3 files changed, 4 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c0aa92c56f..9d7b50ea87 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1388,7 +1388,6 @@ dist_patch_DATA = \
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
%D%/packages/patches/spice-fix-test-armhf.patch \
%D%/packages/patches/steghide-fixes.patch \
- %D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
%D%/packages/patches/superlu-dist-awpm-grid.patch \
%D%/packages/patches/superlu-dist-fix-mpi-deprecations.patch \
%D%/packages/patches/superlu-dist-scotchmetis.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 34135afe0c..5c1285cce9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2249,24 +2249,22 @@ background file post-processing.")
(define-public supercollider
(package
(name "supercollider")
- (version "3.10.3")
+ (version "3.10.4")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/supercollider/supercollider"
"/releases/download/Version-" version
"/SuperCollider-" version "-Source-linux.tar.bz2"))
- (patches
- (search-patches "supercollider-boost-1.70-build-fix.patch"))
(sha256
(base32
- "0srm6wbazidkrd4ckjy4ypyhkdwcnx2i7k9msjyngalh0mrc9zz1"))))
+ "0x11g3pfw11m6v18qfpfl5w99dbmf73g4z7wvwhrj1a4qv2dn084"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DSYSTEM_BOOST=on" "-DSYSTEM_YAMLCPP=on"
"-DSC_QT=off"
"-DSC_EL=off") ;scel is packaged individually as
- ;emacs-scel.
+ ;emacs-scel
#:modules ((guix build utils)
(guix build cmake-build-system)
(ice-9 ftw))
@@ -2275,8 +2273,7 @@ background file post-processing.")
(add-after 'unpack 'rm-bundled-libs
(lambda _
;; The build system doesn't allow us to unbundle the following
- ;; libraries. hidapi is also heavily patched and upstream not
- ;; actively maintained.
+ ;; libraries. hidapi is also heavily patched.
(let ((keep-dirs '("nova-simd" "nova-tt" "hidapi" "TLSF-2.4.6"
"oscpack_1_1_0" "." "..")))
(with-directory-excursion "./external_libraries"
diff --git a/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch b/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
deleted file mode 100644
index 073044fccb..0000000000
--- a/gnu/packages/patches/supercollider-boost-1.70-build-fix.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Patches taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/supercollider/files/supercollider-3.10.2-boost-1.70.patch?id=a420618dc766bba0654dbe0ef67008fdc5e901c6 to fix supercollider build with boost 1.70.
-
-diff --git a/server/supernova/sc/sc_osc_handler.cpp b/server/supernova/sc/sc_osc_handler.cpp
-index 5116a1be87..96e937ec25 100644
---- a/server/supernova/sc/sc_osc_handler.cpp
-+++ b/server/supernova/sc/sc_osc_handler.cpp
-@@ -728,7 +728,8 @@ void sc_osc_handler::tcp_connection::handle_message() {
-
-
- void sc_osc_handler::start_tcp_accept(void) {
-- tcp_connection::pointer new_connection = tcp_connection::create(tcp_acceptor_.get_io_service());
-+ tcp_connection::pointer new_connection =
-+ tcp_connection::create((boost::asio::io_context&)tcp_acceptor_.get_executor().context());
-
- tcp_acceptor_.async_accept(
- new_connection->socket(),
-diff --git a/server/supernova/utilities/utils.hpp b/server/supernova/utilities/utils.hpp
-index 35b8ab5ad..a7c191f2d 100644
---- a/server/supernova/utilities/utils.hpp
-+++ b/server/supernova/utilities/utils.hpp
-@@ -23,6 +23,7 @@
-
- #include <type_traits>
-
-+#include <boost/checked_delete.hpp>
- #include <boost/intrusive_ptr.hpp>
- #include <boost/noncopyable.hpp>
- #include <boost/detail/atomic_count.hpp>