summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-21 00:23:09 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-21 01:12:05 +0100
commit16829d3b8a795d6a4bef32bfab1f10be2f466f23 (patch)
tree285fef9fa07e0ebc46d831667aaeb6f3a0f9b1c5
parent2624921a64727d137505c6f104692d2b88845a98 (diff)
downloadpatches-16829d3b8a795d6a4bef32bfab1f10be2f466f23.tar
patches-16829d3b8a795d6a4bef32bfab1f10be2f466f23.tar.gz
gnu: ocaml-lwt: Update to 5.1.1.
* gnu/packages/ocaml.scm (ocaml-lwt): update to 5.1.1.
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7e71f7627f..0fc4a24172 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1762,7 +1762,7 @@ for mapping files in memory. This function is the same as the
(define-public ocaml-lwt
(package
(name "ocaml-lwt")
- (version "4.1.0")
+ (version "5.1.1")
(source
(origin
(method url-fetch)
@@ -1770,29 +1770,22 @@ for mapping files in memory. This function is the same as the
".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256 (base32
- "0mhh019bjkg5xfvpy1pxs4xdxb759fyydmgb6l4j0qww1qgr8klp"))))
+ "0gwdmhn0qx03agc45dplj73ia5y1gb42aan64ywfxmll3lsnr2h7"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #f; require lwt_ppx
- #:jbuild? #t
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'configure
- (lambda _
- (invoke "ocaml" "src/util/configure.ml" "-use-libev" "true")
- #t)))))
+ `(#:package "lwt"))
(native-inputs
- `(("ocaml-cppo" ,ocaml-cppo)
- ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
- ("pkg-config" ,pkg-config)
- ("ppx-tools-versioned" ,ocaml-ppx-tools-versioned)))
+ `(("ocaml-bisect-ppx" ,ocaml-bisect-ppx)
+ ("ocaml-cppo" ,ocaml-cppo)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("libev" ,libev)
("glib" ,glib)))
(propagated-inputs
- `(("result" ,ocaml-result)
- ("ocaml-ssl" ,ocaml-ssl)
- ("ocaml-react" ,ocaml-react)))
+ `(("ocaml-mmap" ,ocaml-mmap)
+ ("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
+ ("ocaml-result" ,ocaml-result)
+ ("ocaml-seq" ,ocaml-seq)))
(home-page "https://github.com/ocsigen/lwt")
(synopsis "Cooperative threads and I/O in monadic style")
(description "Lwt provides typed, composable cooperative threads. These