summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 00:08:41 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 03:57:30 +0100
commitdf01360f7897e8eacdc4c1156443018b15f42fdc (patch)
tree5223854891c506f2b8ed7596918e946bc1ebe766
parent02d6e27e15d66ef557b90479a7920aabd15e42bf (diff)
downloadpatches-df01360f7897e8eacdc4c1156443018b15f42fdc.tar
patches-df01360f7897e8eacdc4c1156443018b15f42fdc.tar.gz
gnu: python-publicsuffix2: Update to 2.20191221.
* gnu/packages/python-web.scm (python-publicsuffix2): Update to 2.20191221. [arguments]: Add ‘ignore-maintainer-inputs’ phase.
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 179e64e0a1..611c85a9ad 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
@@ -2748,17 +2748,26 @@ List.")
(define-public python-publicsuffix2
(package
(name "python-publicsuffix2")
- (version "2.20160818")
+ (version "2.20191221")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "publicsuffix2" version ".tar.bz2"))
+ (uri (pypi-uri "publicsuffix2" version))
(sha256
- (base32
- "1bb55yka9vkn7i6y1kjzxa516kh6v4gsrxa90w5wdz5p5n968r68"))))
+ (base32 "0yzysvfj1najr1mb4pcqrbmjir3xpb69rlffln95a3cdm8qwry00"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; The test suite requires network access.
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'ignore-maintainer-inputs
+ (lambda _
+ ;; Comment out a demand for python-requests, which is used only by
+ ;; the unused ‘update_psl’ helper command.
+ (substitute* "setup.py"
+ (("'requests " match)
+ (format "# ~a" match)))
+ #t)))
+ #:tests? #f)) ; the test suite requires network access
(home-page "https://github.com/pombredanne/python-publicsuffix2")
(synopsis "Get a public suffix for a domain name using the Public Suffix List")
(description "Get a public suffix for a domain name using the Public Suffix