summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-24 19:59:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-24 20:22:00 +0300
commitc80f837afdbc1aba1c7c9b6c20710fcd830b0767 (patch)
tree32cc97575a0a80547b23f9916d4bda904b6047ce
parent030030f4416b54285dcdd58bddb863c0e6bda4c4 (diff)
downloadpatches-c80f837afdbc1aba1c7c9b6c20710fcd830b0767.tar
patches-c80f837afdbc1aba1c7c9b6c20710fcd830b0767.tar.gz
gnu: fontforge: Update to 20170731.
* gnu/packages/fontutils.scm (fontforge): Update to 20170731. [source]: Remove patch, remove snippet. [arguments]: Enable tests. Remove phase to build showttf. [inputs]: Use python-wrapper instead of python. [home-page]: Update to new home page. * gnu/packages/patches/fontforge-svg-modtime.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/fontutils.scm33
-rw-r--r--gnu/packages/patches/fontforge-svg-modtime.patch35
3 files changed, 6 insertions, 63 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 711f38c6b4..acae773269 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -617,7 +617,6 @@ dist_patch_DATA = \
%D%/packages/patches/flint-ldconfig.patch \
%D%/packages/patches/fltk-shared-lib-defines.patch \
%D%/packages/patches/fltk-xfont-on-demand.patch \
- %D%/packages/patches/fontforge-svg-modtime.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index bd74c4d6aa..102def93de 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -507,26 +507,14 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20160404")
+ (version "20170731")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
- version "/fontforge-dist-" version ".tar.gz"))
+ version "/fontforge-dist-" version ".tar.xz"))
(sha256 (base32
- "1kavnhbkzc1hk6f39fynq9s0haama81ddrbld4b5x60d0dbaawvc"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Make builds bit-reproducible by using fixed date strings.
- (substitute* "configure"
- (("^FONTFORGE_MODTIME=.*$")
- "FONTFORGE_MODTIME=\"1459819518L\"\n")
- (("^FONTFORGE_MODTIME_STR=.*$")
- "FONTFORGE_MODTIME_STR=\"20:25 CDT 4-Apr-2016\"\n")
- (("^FONTFORGE_VERSIONDATE=.*$")
- "FONTFORGE_VERSIONDATE=\"20160404\"\n"))))
- (patches (list (search-patch "fontforge-svg-modtime.patch")))))
+ "08l8h3yvk4v7652jvmd3ls7nf5miybkx2fmkf1mpwwfixpxxw2l4"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -550,20 +538,11 @@ definitions.")
("libxml2" ,libxml2)
("pango" ,pango)
("potrace" ,potrace)
- ("python" ,python)
+ ("python" ,python-wrapper)
("zlib" ,zlib)))
(arguments
- '(#:tests? #f
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after 'build 'build-contrib
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (and (zero? (system* "make" "-Ccontrib/fonttools"
- "CC=gcc" "showttf"))
- (begin (install-file "contrib/fonttools/showttf" bin)
- #t)))))
(add-after 'install 'set-library-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -585,4 +564,4 @@ definitions.")
opentype fonts. You can save fonts in many different outline formats, and
generate bitmaps.")
(license license:gpl3+)
- (home-page "http://fontforge.org/")))
+ (home-page "https://fontforge.github.io/en-US/")))
diff --git a/gnu/packages/patches/fontforge-svg-modtime.patch b/gnu/packages/patches/fontforge-svg-modtime.patch
deleted file mode 100644
index fd960ae610..0000000000
--- a/gnu/packages/patches/fontforge-svg-modtime.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Propagate source font modification time to svg during conversion. Similar to
-what upstream commit 95a470e941d9a20fbdaca51334e8b6b9d93cfae4 did for TTF
-files.
-
-Submitted upstream at http://github.com/fontforge/fontforge/pull/2696
-
---- a/fontforge/svg.c
-+++ b/fontforge/svg.c
-@@ -27,7 +27,6 @@
- #include "fontforgevw.h"
- #include <unistd.h>
- #include <math.h>
--#include <time.h>
- #include <locale.h>
- #include <utype.h>
- #include <chardata.h>
-@@ -62,7 +61,6 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
- BlueData bd;
- char *hash, *hasv, ch;
- int minu, maxu, i;
-- time_t now;
- const char *author = GetAuthor();
-
- memset(&info,0,sizeof(info));
-@@ -78,9 +76,8 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) {
- fprintf( file, "\n-->\n" );
- }
- fprintf( file, "<svg xmlns=\"http://www.w3.org/2000/svg\" xmlns:xlink=\"http://www.w3.org/1999/xlink\" version=\"1.1\">\n" );
-- time(&now);
- fprintf( file, "<metadata>\nCreated by FontForge %d at %s",
-- FONTFORGE_VERSIONDATE_RAW, ctime(&now) );
-+ FONTFORGE_VERSIONDATE_RAW, ctime((time_t*)&sf->modificationtime) );
- if ( author!=NULL )
- fprintf(file," By %s\n", author);
- else