summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-09-25 11:42:07 +0100
committerLudovic Courtès <ludo@gnu.org>2017-09-26 00:35:06 +0200
commit8ddf20b286226e0e777c95046d824b1e586277c9 (patch)
tree121a360d6ffae8d00a81790c7c3180211d07fba5
parent66660960ba75233ae5b6c539f43d97d06d64e9ad (diff)
downloadpatches-8ddf20b286226e0e777c95046d824b1e586277c9.tar
patches-8ddf20b286226e0e777c95046d824b1e586277c9.tar.gz
gnu: lm-sensors: Add "lib" output.
* gnu/packages/linux.scm (lm-sensors)[outputs]: Add "lib". [arguments]: Fix up make flags. (xsensors)[inputs]: Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c9888fad2..f13fbb0521 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2368,11 +2368,16 @@ country-specific regulations for the wireless spectrum.")
("flex" ,flex)
("bison" ,bison)
("which" ,which)))
+ (outputs '("lib" ;avoid perl in closure
+ "out"))
(arguments
`(#:tests? #f ; no 'check' target
#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "ETCDIR=" %output "/etc")
- (string-append "MANDIR=" %output "/share/man"))
+ (string-append "ETCDIR=" (assoc-ref %outputs "lib") "/etc")
+ (string-append "INCLUDEDIR="
+ (assoc-ref %outputs "lib") "/include")
+ (string-append "MANDIR=" %output "/share/man")
+ (string-append "LIBDIR=" (assoc-ref %outputs "lib") "/lib"))
#:phases
(alist-delete
'configure
@@ -2462,7 +2467,7 @@ SMBus access.")
(base32
"1siplsfgvcxamyqf44h71jx6jdfmvhfm7mh0y1q8ps4zs6pj2zwh"))))
(build-system gnu-build-system)
- (inputs `(("lm-sensors" ,lm-sensors)
+ (inputs `(("lm-sensors" ,lm-sensors "lib")
("gtk" ,gtk+-2)))
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments