summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-16 22:34:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-17 09:53:19 +0200
commit759dfa989e5f5fbc91ac618243333112c641cf15 (patch)
treedcb4df810dd8c743cad03591bcdf0a9711676c07
parent6c92f52b2ea1998678713505f4c5af70efc3792b (diff)
downloadpatches-759dfa989e5f5fbc91ac618243333112c641cf15.tar
patches-759dfa989e5f5fbc91ac618243333112c641cf15.tar.gz
gnu: rust-libc-0.2: Don't hide package.
* gnu/packages/crates-io.scm (rust-libc-0.2)[arguments]: Skip build. Add rust-rustc-std-workspace-core-1.0 to cargo-inputs. [description]: Appease 'guix lint'. [properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8879096115..8f62e89a75 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4964,19 +4964,21 @@ requires non-const function calls to be computed.")
(base32
"1s14bjxnz6haw0gr1h3j4sr7s2s407hpgm8dxhwnl7yzgxia0c8s"))))
(build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1.0))))
(home-page "https://github.com/rust-lang/libc")
(synopsis "Raw FFI bindings to platform libraries like libc")
(description
- "libc provides all of the definitions necessary to easily
-interoperate with C code (or \"C-like\" code) on each of the platforms
-that Rust supports. This includes type definitions (e.g., c_int),
-constants (e.g., EINVAL) as well as function headers (e.g., malloc).
+ "The rust libc crate provides all of the definitions necessary to easily
+interoperate with C code (or \"C-like\" code) on each of the platforms that Rust
+supports. This includes type definitions (e.g., c_int), constants (e.g., EINVAL)
+as well as function headers (e.g., malloc).
-This crate exports all underlying platform types, functions, and
-constants under the crate root, so all items are accessible as
-@samp{libc::foo}. The types and values of all the exported APIs match
-the platform that libc is compiled for.")
- (properties '((hidden? . #t)))
+This crate exports all underlying platform types, functions, and constants under
+the crate root, so all items are accessible as @samp{libc::foo}. The types and
+values of all the exported APIs match the platform that libc is compiled for.")
(license (list license:expat
license:asl2.0))))