summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-01-04 22:36:03 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-01-17 15:19:14 -0500
commit63ca1a89086574c52eeab8f223687e8614e33ffe (patch)
tree3d71ae69482e1b3009bb64b7873054fde7d5ddc0
parentdc4469e9683c73fd4d03c1708cc4178b300f53a5 (diff)
downloadpatches-63ca1a89086574c52eeab8f223687e8614e33ffe.tar
patches-63ca1a89086574c52eeab8f223687e8614e33ffe.tar.gz
gnu: Add opensp.
* gnu/packages/finance.scm (opensp): New variable.
-rw-r--r--gnu/packages/finance.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 19f990848c..466e91c142 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,10 +53,12 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages dns)
#:use-module (gnu packages emacs)
#:use-module (gnu packages dbm)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -1202,3 +1205,53 @@ offers confimations after less than 5 seconds and have significantly lower
fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
Cash protocol. This package provides the Bitcoin Cash command line client and
a client based on Qt. This is a fork of Bitcoin Core.")))
+
+(define-public opensp
+ (package
+ (name "opensp")
+ (version "1.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/openjade/opensp/"
+ version "/OpenSP-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1khpasr6l0a8nfz6kcf3s81vgdab8fm2dj291n5r2s53k228kx2p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("docbook-xml" ,docbook-xml-4.1.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("xmlto" ,xmlto)))
+ (arguments
+ `(;; TODO: Fix and enable tests.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook"))
+ (xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl))))
+ (substitute* (find-files "docsrc" "\\.xml$")
+ (("/usr/share/sgml/docbook/xml-dtd-4.1.2") xmldoc)
+ (("http://.*/docbookx\\.dtd")
+ (string-append xmldoc "/docbookx.dtd")))
+ ;; Directly pass the path to the stylesheet to xmlto.
+ (substitute* "docsrc/Makefile.in"
+ (("\\$\\(XMLTO\\)")
+ (string-append "$(XMLTO) -x " xsldoc
+ "/manpages/docbook.xsl")))
+ #t))))))
+ (home-page "http://openjade.sourceforge.net/")
+ (synopsis "Suite of SGML/XML processing tools")
+ (description "OpenSP is an object-oriented toolkit for SGML parsing and
+entity management.")
+ (license
+ ;; expat license with added clause regarding advertising
+ (license:non-copyleft
+ "file://COPYING"
+ "See COPYING in the distribution."))))