summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-17 09:37:03 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-17 13:44:38 +0100
commit5b8bc813bacbc9f3b9820ffff660096285751c56 (patch)
tree62ab207590f26fa01ea5efc18a3f008728504a9b
parent4101c7148da3b7cbacdba611bbfe0487544446dd (diff)
downloadpatches-5b8bc813bacbc9f3b9820ffff660096285751c56.tar
patches-5b8bc813bacbc9f3b9820ffff660096285751c56.tar.gz
gnu: Add cl-vom.
* gnu/packages/lisp-xyz.scm (sbcl-vom, cl-vom, ecl-vom): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 97af7f25f0..0b707328b5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9382,3 +9382,34 @@ continuations of the @code{cl-cont} library.")
(define-public ecl-cl-coroutine
(sbcl-package->ecl-package sbcl-cl-coroutine))
+
+(define-public sbcl-vom
+ (let ((commit "1aeafeb5b74c53741b79497e0ef4acf85c92ff24")
+ (revision "1"))
+ (package
+ (name "sbcl-vom")
+ (version (git-version "0.1.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/orthecreedence/vom.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0536kppj76ax4lrxhv42npkfjsmx45km2g439vf9jmw3apinz9cy"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Tiny logging utility for Common Lisp")
+ (description
+ "Vom is a logging library for Common Lisp. It's goal is to be useful
+and small. It does not provide a lot of features as other loggers do, but
+has a small codebase that's easy to understand and use.")
+ (home-page "https://github.com/orthecreedence/vom")
+ (license license:expat))))
+
+(define-public cl-vom
+ (sbcl-package->cl-source-package sbcl-vom))
+
+(define-public ecl-vom
+ (sbcl-package->ecl-package sbcl-vom))