summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 22:39:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-17 23:32:34 +0100
commit3497086b6b4f2b39f7e74c0fe824abc7c6f1d118 (patch)
tree0ce14fe12bb5b5fd782e07e9f56892ee5c52ae00
parent9a50f47c49a98318828aa0130fce436e795175d5 (diff)
downloadpatches-3497086b6b4f2b39f7e74c0fe824abc7c6f1d118.tar
patches-3497086b6b4f2b39f7e74c0fe824abc7c6f1d118.tar.gz
gnu: Use HTTPS for sass-lang.com everywhere.
* gnu/packages/ruby.scm (ruby-sass)[home-page]: Use HTTPS. * gnu/packages/web.scm (sassc)[home-page]: Likewise.
-rw-r--r--gnu/packages/ruby.scm2
-rw-r--r--gnu/packages/web.scm9
2 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ad675dc488..fa913beab4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7755,7 +7755,7 @@ the @file{spec} directory.")
(native-inputs
`(("ruby-sass-spec" ,ruby-sass-spec)
("ruby-mathn" ,ruby-mathn)))
- (home-page "http://sass-lang.com/")
+ (home-page "https://sass-lang.com/")
(synopsis "CSS extension language")
(description "Sass is a CSS extension language. It extends CSS with
features that don't exist yet like variables, nesting, mixins and inheritance.")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5b457ccc5b..904db3828b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1565,8 +1565,7 @@ stylesheets, you'll need to use another program that uses this library,
`(#:make-flags
(list "CC=gcc"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
- ;; I don't believe sassc contains any tests
- #:tests? #f
+ #:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-Makefile
@@ -1579,9 +1578,9 @@ stylesheets, you'll need to use another program that uses this library,
(("install: libsass-install-\\$\\(BUILD\\) \\\\")
"install: \\"))
#t))
- ;; This phase fails for some reason
+ ;; This phase fails for some reason.
(delete 'bootstrap)
- ;; There is no configure script
+ ;; There is no configure script.
(delete 'configure)
(add-before 'build 'setup-environment
(lambda _
@@ -1593,7 +1592,7 @@ stylesheets, you'll need to use another program that uses this library,
(synopsis "CSS pre-processor")
(description "SassC is a compiler written in C for the CSS pre-processor
language known as SASS.")
- (home-page "http://sass-lang.com/libsass")
+ (home-page "https://sass-lang.com/libsass")
(license license:expat)))