summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 17:43:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-16 19:20:21 +0100
commitf2d56e39934d14f2107ede8598e228c461c7b44d (patch)
treecee94818a61bb1abd6ab0f7913b812dbe8099edb
parent7152a7143186d7540c1f67decb7842c7a103903b (diff)
downloadpatches-f2d56e39934d14f2107ede8598e228c461c7b44d.tar
patches-f2d56e39934d14f2107ede8598e228c461c7b44d.tar.gz
gnu: libpeas: Update to 1.24.1.
* gnu/packages/gnome.scm (libpeas): Update to 1.24.1. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: New field. [native-inputs]: Remove INTLTOOL. ADD GETTEXT-MINIMAL and XORG-SERVER-FOR-TESTS.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a6a8307649..9cf3cbb07d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2018, 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
@@ -1883,7 +1883,7 @@ some form of information without getting in the user's way.")
(define-public libpeas
(package
(name "libpeas")
- (version "1.22.0")
+ (version "1.24.1")
(source
(origin
(method url-fetch)
@@ -1892,8 +1892,19 @@ some form of information without getting in the user's way.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0qm908kisyjzjxvygdl18hjqxvvgkq9w0phs2g55pck277sw0bsv"))))
- (build-system gnu-build-system)
+ "1162dr7smmfb02czmhshr0f93hqj7w0nw29bys5lzfvwarxcyflw"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xserver
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xorg-server (assoc-ref inputs "xorg-server"))
+ (disp ":1"))
+ (setenv "DISPLAY" disp)
+ ;; Tests require a running X server.
+ (system (format #f "~a/bin/Xvfb ~a &" xorg-server disp))
+ #t))))))
(inputs
`(("gtk+" ,gtk+)
("glade" ,glade3)
@@ -1901,9 +1912,10 @@ some form of information without getting in the user's way.")
("python-pygobject" ,python-pygobject)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)))
+ ("xorg-server" ,xorg-server-for-tests)))
(propagated-inputs
;; The .pc file "Requires" gobject-introspection.
`(("gobject-introspection" ,gobject-introspection)))