summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 01:31:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-16 19:51:55 +0100
commitbd9f588b37a86845604fbe8506bdfe162ba578b3 (patch)
treebd84d15c47c66f62bfb4b3a60fce4b887627ec59
parent2c31cf87e3f8476c45e32ced1534f5a7bc2d01b5 (diff)
downloadpatches-bd9f588b37a86845604fbe8506bdfe162ba578b3.tar
patches-bd9f588b37a86845604fbe8506bdfe162ba578b3.tar.gz
gnu: noweb: Embed store references to external binaries.
* gnu/packages/noweb.scm (noweb)[argument]: Add ‘bind-early’ phase. [inputs]: Add perl.
-rw-r--r--gnu/packages/noweb.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/noweb.scm b/gnu/packages/noweb.scm
index 0a0010c6dd..2fcd24c6e2 100644
--- a/gnu/packages/noweb.scm
+++ b/gnu/packages/noweb.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,7 +21,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (guix licenses))
+ #:use-module (guix licenses)
+ #:use-module (gnu packages perl))
(define-public noweb
(package
@@ -37,6 +39,18 @@
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'bind-early
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (substitute* (list "src/lib/nwmtime"
+ "src/shell/htmltoc")
+ (("exec perl ")
+ (format #f "exec ~a " (which "perl"))))
+ (substitute* "src/shell/noweb"
+ ((" cpif ")
+ (format #f " ~a/cpif " bin)))
+ #t)))
(add-before 'install 'pre-install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -82,6 +96,8 @@
(string-append "TEXINPUTS=" out
"/share/texmf/tex/latex")))
#:tests? #f)) ; no tests
+ (inputs
+ `(("perl" ,perl)))
(home-page "https://www.cs.tufts.edu/~nr/noweb/")
(synopsis "Literate programming tool")
(description