summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-16 17:53:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-16 19:36:26 +0200
commit671d08f30d5a12a4865fede3dfa56f604637ad63 (patch)
tree61c81e7aa96a926829054a3d309df3a8d84f9ea7
parentfcc4e04d2271d7ae862a9f40775d3c3e3f083fdc (diff)
downloadpatches-671d08f30d5a12a4865fede3dfa56f604637ad63.tar
patches-671d08f30d5a12a4865fede3dfa56f604637ad63.tar.gz
gnu: rust-scoped-tls-1.0: Don't hide package.
* gnu/packages/crates-io.scm (rust-scoped-tls-1.0)[arguments]: Skip build. [properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f0f9387438..129d5d4770 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8720,12 +8720,12 @@ non-'static references in parallel.")
(base32
"1hj8lifzvivdb1z02lfnzkshpvk85nkgzxsy2hc0zky9wf894spa"))))
(build-system cargo-build-system)
+ (arguments '(#:skip-build? #t))
(home-page "https://github.com/alexcrichton/scoped-tls")
(synopsis "Rust library providing the old standard library's scoped_thread_local")
(description "This crate provides a library implementation of the standard
library's old @code{scoped_thread_local!} macro for providing scoped access to
@dfn{thread local storage} (TLS) so any type can be stored into TLS.")
- (properties '((hidden? . #t)))
(license (list license:asl2.0
license:expat))))
@@ -8741,9 +8741,7 @@ library's old @code{scoped_thread_local!} macro for providing scoped access to
(file-name (string-append name "-" version ".crate"))
(sha256
(base32
- "0a2bn9d2mb07c6l16sadijy4p540g498zddfxyiq4rsqpwrglbrk"))))
- (arguments '(#:skip-build? #t))
- (properties '())))
+ "0a2bn9d2mb07c6l16sadijy4p540g498zddfxyiq4rsqpwrglbrk"))))))
(define-public rust-scopeguard-1.0
(package