summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-16 16:49:23 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-16 17:09:48 +0100
commit602f3b679325c30b62201999f1d4f211f08fc0e5 (patch)
tree86119fc8d9203e8dfb61d89beefa43985c8b5baa
parentd14e4745b36a835c6babd5b5f5562e12294cd9cf (diff)
downloadpatches-602f3b679325c30b62201999f1d4f211f08fc0e5.tar
patches-602f3b679325c30b62201999f1d4f211f08fc0e5.tar.gz
gnu: Add python-speg.
* gnu/packages/python-xyz.scm (python-speg): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 479466cc81..97da0974e0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17073,3 +17073,24 @@ scripts to load entry points more quickly.")
functional combinators. Parser combinators are just higher-order functions
that take parsers as their arguments and return them as result values.")
(license license:expat)))
+
+(define-public python-speg
+ (package
+ (name "python-speg")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "speg" version ".zip"))
+ (sha256
+ (base32 "0w9y4jf4787dzhy6rvhwi0mpl0r8qkqmqmyv2hpwdpv8w53yzjqh"))))
+ (arguments
+ `(#:tests? #f)) ;FIXME: tests fail, not sure why
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (build-system python-build-system)
+ (home-page "https://github.com/avakar/speg")
+ (synopsis "PEG-based parser interpreter with memoization")
+ (description "This package is a PEG-based parser and interpreter with
+memoization.")
+ (license license:expat)))