summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-12 15:23:19 -0500
committerLudovic Courtès <ludo@gnu.org>2020-01-15 23:48:32 +0100
commit47e8709369b80e728f832207a83b61fcc789bb21 (patch)
tree5393b4b7f0df8cce3a30574f3386b816f8594d7c
parentbcc8a8fd1e3ac64e096e8b9495e02ad6830a8e41 (diff)
downloadpatches-47e8709369b80e728f832207a83b61fcc789bb21.tar
patches-47e8709369b80e728f832207a83b61fcc789bb21.tar.gz
gnu: Add libnma.
* gnu/packages/gnome.scm (libnma): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a238dab814..06aafa7037 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -582,6 +582,44 @@ sharing to the masses.")
(home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
(license license:gpl2+)))
+(define-public libnma
+ (package
+ (name "libnma")
+ (version "1.8.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1w9lld38risnk1krknfwln24kabdxnj274pyz4jhndphwigrshaf"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk-doc" ,gtk-doc)
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("gcr" ,gcr)
+ ("gtk+" ,gtk+)
+ ("iso-codes" ,iso-codes)
+ ("mobile-broadband-provider-info" ,mobile-broadband-provider-info)
+ ("network-manager" ,network-manager)))
+ (synopsis "Network Manager's applet library")
+ (description "Libnma is an applet library for Network Manager. It was
+initially part of network-manager-applet and has now become a separate
+project.")
+ (home-page "https://gitlab.gnome.org/GNOME/libnma")
+
+ ;; Some files carry the "GPL-2.0+" SPDX identifier while others say
+ ;; "LGPL-2.1+".
+ (license license:gpl2+)))
+
(define-public gnome-menus
(package
(name "gnome-menus")