summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 17:22:28 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-16 19:20:21 +0100
commit3dfb3d44f316f95401558fb32b3b3e4e464f419c (patch)
tree5bb2b0b9b2a8085d840936f19972b4ed66a5c675
parentfdd0c36963a62577f7a8f99a44f79a7330a0b151 (diff)
downloadpatches-3dfb3d44f316f95401558fb32b3b3e4e464f419c.tar
patches-3dfb3d44f316f95401558fb32b3b3e4e464f419c.tar.gz
gnu: python-importlib-metata: Delay python2 variant.
This is a follow-up to commit 5efa04dd935ecf6f7803501b1b8952810f4330ad. * gnu/packages/python-xyz.scm (python-importlib-metadata)[properties]: New field.
-rw-r--r--gnu/packages/python-xyz.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee2fc11eb1..6bb2a5a5be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5008,6 +5008,7 @@ its top-level name. This functionality intends to replace most uses of
@code{pkg_resources} entry point API and metadata API. Along with
@code{importlib.resources} in Python 3.7 and newer, this can eliminate the
need to use the older and less efficient @code{pkg_resources} package.")
+ (properties `((python2-variant . ,(delay python2-importlib-metadata))))
(license license:asl2.0)))
(define-public python2-importlib-metadata