summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-16 18:42:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-16 19:20:22 +0100
commit34aa9144786658498ff8d4b6b36ac0ae5bf1d454 (patch)
tree0f72043b3df6c34fd17ebe19a6a06220751d7921
parent9f7f5ba2d26b4e64d808419ee2212a302ec81a59 (diff)
downloadpatches-34aa9144786658498ff8d4b6b36ac0ae5bf1d454.tar
patches-34aa9144786658498ff8d4b6b36ac0ae5bf1d454.tar.gz
gnu: python-graphviz: Update to 0.13.2.
* gnu/packages/graphviz.scm (python-graphviz): Update to 0.13.2. [native-inputs]: Add GRAPHVIZ, PYTHON-MOCK, PYTHON-PYTEST, PYTHON-PYTEST-COV, and PYTHON-PYTEST-MOCK. [arguments]: Replace 'check' phase.
-rw-r--r--gnu/packages/graphviz.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index eb4b211daf..365fe1a113 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -166,16 +167,31 @@ interfaces for other technical domains.")
(define-public python-graphviz
(package
(name "python-graphviz")
- (version "0.8.4")
+ (version "0.13.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "graphviz" version ".zip"))
(sha256
(base32
- "17v8h7j2yz8hy1jf7q8p0ik8dmf32m58lc6v11x7aqc4pnfa2n29"))))
+ "009alrilzx0v7kl41khbq7k6k8b8pxyvbsi1b1ai933f6kpbxb30"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests #:allow-other-keys)
+ (if tests
+ (invoke "pytest" "-vv")
+ (format #t "test suite not run~%"))
+ #t)))))
(native-inputs
- `(("unzip" ,unzip)))
+ `(("unzip" ,unzip)
+
+ ;; For tests.
+ ("graphviz" ,graphviz)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mock" ,python-pytest-mock)))
(home-page "https://github.com/xflr6/graphviz")
(synopsis "Simple Python interface for Graphviz")
(description