summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-16 17:58:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-16 19:36:27 +0200
commit1c70205f8277e4dc2f99d0c79a685028d4c64aed (patch)
tree818099e22eed2fb64ad10af519edb4199f61eb4d
parentac20ab2b4e7f34f1c695c3e51b54bf29bdcb54ed (diff)
downloadpatches-1c70205f8277e4dc2f99d0c79a685028d4c64aed.tar
patches-1c70205f8277e4dc2f99d0c79a685028d4c64aed.tar.gz
gnu: rust-scopeguard-1.0: Don't hide package.
* gnu/packages/crates-io.scm (rust-scopeguard-1.0)[arguments]: Skip build. [properties]: Remove field.
-rw-r--r--gnu/packages/crates-io.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 87725e7937..41ed200296 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8756,6 +8756,7 @@ library's old @code{scoped_thread_local!} macro for providing scoped access to
(base32
"03aay84r1f6w87ckbpj6cc4rnsxkxcfs13n5ynxjia0qkgjiabml"))))
(build-system cargo-build-system)
+ (arguments '(#:skip-build? #t))
(home-page "https://github.com/bluss/scopeguard")
(synopsis "Scope guard which will run a closure even out of scope")
(description "This package provides a RAII scope guard that will run a
@@ -8763,7 +8764,6 @@ given closure when it goes out of scope, even if the code between panics
(assuming unwinding panic). Defines the macros @code{defer!},
@code{defer_on_unwind!}, @code{defer_on_success!} as shorthands for guards
with one of the implemented strategies.")
- (properties '((hidden? . #t)))
(license (list license:asl2.0
license:expat))))
@@ -8780,9 +8780,7 @@ with one of the implemented strategies.")
(string-append name "-" version ".crate"))
(sha256
(base32
- "09sy9wbqp409pkwmqni40qmwa99ldqpl48pp95m1xw8sc19qy9cl"))))
- (arguments '(#:skip-build? #t))
- (properties '())))
+ "09sy9wbqp409pkwmqni40qmwa99ldqpl48pp95m1xw8sc19qy9cl"))))))
(define-public rust-scroll-0.9
(package