summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-16 16:49:43 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-16 17:09:48 +0100
commit07c8177b885f1fca367b9cf8befc3328392d79c2 (patch)
treeec2356d5957ba937113bb7c2873302aef7349965
parent602f3b679325c30b62201999f1d4f211f08fc0e5 (diff)
downloadpatches-07c8177b885f1fca367b9cf8befc3328392d79c2.tar
patches-07c8177b885f1fca367b9cf8befc3328392d79c2.tar.gz
gnu: Add python-cson.
* gnu/packages/python-xyz.scm (python-cson): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 97da0974e0..41a2df0cf3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17094,3 +17094,22 @@ that take parsers as their arguments and return them as result values.")
(description "This package is a PEG-based parser and interpreter with
memoization.")
(license license:expat)))
+
+(define-public python-cson
+ (package
+ (name "python-cson")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cson" version))
+ (sha256
+ (base32 "00cyvigg4npbph39ghkg77xbxisa6plf75vii24igxfizik0337f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-speg" ,python-speg)))
+ (home-page "https://github.com/avakar/pycson")
+ (synopsis "Parser for Coffeescript Object Notation (CSON)")
+ (description "This package is a parser for Coffeescript Object
+Notation (CSON).")
+ (license license:expat)))