summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-14 16:20:51 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-14 16:45:26 +0100
commitf35b596e50fec332e33162407a926ff3bdb6ec52 (patch)
tree6ec27690d1e8edb7593d94ee8cd31162336f79d0
parent9f37129f91f6d3485d3b92fceb8f619046000618 (diff)
downloadpatches-f35b596e50fec332e33162407a926ff3bdb6ec52.tar
patches-f35b596e50fec332e33162407a926ff3bdb6ec52.tar.gz
gnu: Add cl-archive.
* gnu/packages/lisp-xyz.scm (sbcl-archive, cl-archive, ecl-archive): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cffd43cfc7..ae59a97a21 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9168,3 +9168,35 @@ visualization.")
(define-public cl-ana
(sbcl-package->cl-source-package sbcl-cl-ana))
+
+(define-public sbcl-archive
+ (let ((commit "631271c091ed02994bec3980cb288a2cf32c7cdc")
+ (revision "1"))
+ (package
+ (name "sbcl-archive")
+ (version (git-version "0.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sharplispers/archive.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pvsc9fmybx7rxd0kmzq4shi6hszdpwdc1sfy7jwyfxf8n3hnv4p"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-fad" ,sbcl-cl-fad)
+ ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+ (synopsis "Common Lisp library for tar and cpio archives")
+ (description
+ "This is a Common Lisp library to read and write disk-based file
+archives such as those generated by the tar and cpio programs on Unix.")
+ (home-page "https://github.com/sharplispers/archive")
+ (license license:bsd-3))))
+
+(define-public cl-archive
+ (sbcl-package->cl-source-package sbcl-archive))
+
+(define-public ecl-archive
+ (sbcl-package->ecl-package sbcl-archive))