summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-13 23:09:44 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-13 23:13:05 +0100
commite7fc77464171bbca463e3e5dbcd9cc4789849ca9 (patch)
treec90323273f5977c4845a7872c9debc0b0cc8f8d8
parent015bb1c8db1d28133279d36ac447a8c0d52384b1 (diff)
downloadpatches-e7fc77464171bbca463e3e5dbcd9cc4789849ca9.tar
patches-e7fc77464171bbca463e3e5dbcd9cc4789849ca9.tar.gz
gnu: guile-newt: Add "guile3.0-newt" variant.
* gnu/packages/guile-xyz.scm (guile-newt)[source]: Add 'modules' and 'snippet'. (guile3.0-newt): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9f95245988..955937336b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -996,7 +996,20 @@ format.")
(file-name (git-file-name name version))
(sha256
(base32
- "1w7qy4dw1f4bx622l6hw8mv49sf1ha8kch8j4nganyk8fj0wn695"))))
+ "1w7qy4dw1f4bx622l6hw8mv49sf1ha8kch8j4nganyk8fj0wn695"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure.ac"
+ (("^GUILE_PKG.*")
+ "GUILE_PKG([3.0 2.2 2.0])\n"))
+
+ ;; Remove "guile.m4" since it contains an obsolete version
+ ;; of 'GUILE_PKG' that doesn't work with development
+ ;; versions such as 2.9.
+ (delete-file "m4/guile.m4")
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -1016,6 +1029,13 @@ Scheme by using Guile’s foreign function interface.")
(home-page "https://gitlab.com/mothacehe/guile-newt")
(license license:gpl3+)))
+(define-public guile3.0-newt
+ (package
+ (inherit guile-newt)
+ (name "guile3.0-newt")
+ (inputs `(("guile" ,guile-next)
+ ,@(alist-delete "guile" (package-inputs guile-newt))))))
+
(define-public guile-mastodon
(package
(name "guile-mastodon")