summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-05-27 21:38:28 -0400
committerDavid Thompson <davet@gnu.org>2015-05-29 20:05:57 -0400
commit98b87b82bef87c7794365e26832bbd1afb013721 (patch)
treec37bba037201962175e80c6f373f1a33907177a5
parent2cbc105bb358ca473e35395b57b5af2c54110567 (diff)
downloadpatches-98b87b82bef87c7794365e26832bbd1afb013721.tar
patches-98b87b82bef87c7794365e26832bbd1afb013721.tar.gz
gnu: Add ruby-useragent.
* gnu/packages/ruby.scm (ruby-useragent): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3d23e74bfa..9943de7e0b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -339,3 +339,28 @@ expectations and mocks frameworks.")
specified in a \"Gemfile\", as well as their dependencies.")
(home-page "http://bundler.io/")
(license license:expat)))
+
+(define-public ruby-useragent
+ (package
+ (name "ruby-useragent")
+ (version "0.13.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/gshutler/useragent/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hj00fw06i0y3rwxxhxmnrqxhpnffv4zfqx2sqqpc5qc4fdvd2x9"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("bundler" ,bundler)))
+ (synopsis "HTTP user agent parser for Ruby")
+ (description "UserAgent is a Ruby library that parses and compares HTTP
+User Agents.")
+ (home-page "https://github.com/gshutler/useragent")
+ (license license:expat)))