summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-13 18:25:34 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-13 18:26:52 +0100
commit8fcb607780dc9809949c573865c5e1a04770d0c5 (patch)
treec3781ca6c808f6063890212f39b7fe2df4931ca5
parent8672e5e9812fe0e84cb96f8e82a79165ef80351c (diff)
downloadpatches-8fcb607780dc9809949c573865c5e1a04770d0c5.tar
patches-8fcb607780dc9809949c573865c5e1a04770d0c5.tar.gz
gnu: perl-gtk2: Skip broken test.
* gnu/packages/gtk.scm (perl-gtk2)[arguments]: Skip broken test.
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index db88c84413..a3e19827f5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1328,6 +1328,16 @@ produces identical output on all those targets.")
`(("gtk+" ,gtk+-2)))
(propagated-inputs
`(("perl-pango" ,perl-pango)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'remove-broken-test
+ ;; See https://gitlab.gnome.org/GNOME/perl-gtk2/issues/3.
+ (lambda _
+ (substitute* "t/GdkPixbuf.t"
+ (("tests => 112") "tests => 111")
+ (("ok \\(defined \\$pixbuf, \"Don't crash on partial pixmap data\"\\);")
+ "# ok (defined $pixbuf, \"Don't crash on partial pixmap data\");")))))))
(home-page "https://metacpan.org/release/Gtk2")
(synopsis "Perl interface to the 2.x series of the Gimp Toolkit library")
(description "Perl bindings to the 2.x series of the Gtk+ widget set.