summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-13 17:37:14 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-13 18:15:19 +0100
commit281f6b3a9e00be224f4727820747c081a0a69b97 (patch)
treea3bd2071405d1b81bda7fd0b0e5e5811aa859384
parent4616f5a8405f2e90aa6183e2d40844dcea6598ca (diff)
downloadpatches-281f6b3a9e00be224f4727820747c081a0a69b97.tar
patches-281f6b3a9e00be224f4727820747c081a0a69b97.tar.gz
gnu: Add grilo-plugins.
* gnu/packages/gnome.scm (grilo-plugins): Update to 0.3.10. [description]: Modify. [build-system]: Use meson-build-system. [native-inputs]: Add gettext, gtk+:bin. [inputs]: Add gnome-online-accounts:lib, libgdata, libmediaart, tracker. Remove sqlite, libxml2, glib, gmime, libarchive. [arguments]<#:make-flags>: Remove. <#:glib-or-gtk?>: Add. <#:configure-flags>: Add -Denable-lua-factory=no. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm47
1 files changed, 22 insertions, 25 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f3e9377f5c..98fab025a6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4690,7 +4690,7 @@ for application developers.")
(define-public grilo-plugins
(package
(name "grilo-plugins")
- (version "0.3.3")
+ (version "0.3.10")
(source
(origin
(method url-fetch)
@@ -4699,44 +4699,41 @@ for application developers.")
name "-" version ".tar.xz"))
(sha256
(base32
- "172vr1y98d2mzlmg5akjn4ibrcj3gh22cwnb3cv9rvvzhj3yhrpy"))))
- (build-system gnu-build-system)
+ "0jldaixc4kzycn5v8ixkjld1n0z3dp0l1p3vchgdwpvdvc7kcfw0"))))
+ (build-system meson-build-system)
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums and glib-genmarshal
- ("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
("itstool" ,itstool)
("pkg-config" ,pkg-config)))
+ ;; TODO: ahavi, gstreamer
(inputs
`(("grilo" ,grilo)
- ("glib" ,glib)
- ("libxml2" ,libxml2)
- ("sqlite" ,sqlite)
+ ;("gmime" ,gmime) ; unused
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gom" ,gom)
- ;; XXX TODO: Add oauth
- ;; XXX TODO: Add goa
- ;; XXX TODO: Add gdata (e.g. needed for youtube plugin)
- ;; XXX TODO: Add lua (needs help finding it)
+ ;("gssdp" ,gssdp) ; unused
+ ;("gupnp" ,gupnp) ; unused
+ ;("gupnp-av" ,gupnp-av) ; unused
("json-glib" ,json-glib)
("avahi" ,avahi)
- ("gmime" ,gmime)
+ ("libgdata" ,libgdata)
+ ("libmediaart" ,libmediaart)
+ ;("librest" ,rest) ; unused
("libsoup" ,libsoup)
- ("libarchive" ,libarchive)
- ("totem-pl-parser" ,totem-pl-parser)))
+ ("totam-pl-parser" ,totem-pl-parser)
+ ("tracker" ,tracker))) ; unused because it's too old
(arguments
- `(#:make-flags (list (string-append "GRL_PLUGINS_DIR="
- %output
- "/lib/grilo-"
- ,(version-major+minor version)))
- ;; XXX FIXME: Try to get the test suite working. It appears to require
- ;; a working system dbus. Inside the build container, all tests fail
- ;; with: "assertion failed: (source)". Outside of the build container,
- ;; most tests succeed.
- #:tests? #f))
+ `(#:glib-or-gtk? #t
+ ;;Disable lua-factory as it needs missing dependencies
+ #:configure-flags '("-Denable-lua-factory=no")))
(home-page "https://live.gnome.org/Grilo")
(synopsis "Plugins for the Grilo media discovery library")
(description
"Grilo is a framework focused on making media discovery and browsing easy
-for application developers.")
+for application developers. This package provides plugins for common media
+discovery protocols.")
(license license:lgpl2.1+)))
(define-public totem