summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-13 07:20:39 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-13 08:34:32 +0100
commite2aed29c798711a765dc3cd7e76f423b2447d22c (patch)
treefba0cfc1a9e17f0ebf0c221a4ab9d837522510c6
parent23174b4986232b560619ff91d6e8a763d4817192 (diff)
downloadpatches-e2aed29c798711a765dc3cd7e76f423b2447d22c.tar
patches-e2aed29c798711a765dc3cd7e76f423b2447d22c.tar.gz
gnu: Add gssdp.
* gnu/packages/gnome.scm (gssdp): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a8e89f51fe..b85af16aaa 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -335,6 +335,37 @@ It has miners for Facebook, Flickr, Google, ownCloud and SkyDrive.")
(home-page "https://wiki.gnome.org/Projects/GnomeOnlineMiners")
(license license:gpl2+)))
+(define-public gssdp
+ (package
+ (name "gssdp")
+ (version "1.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "195hi10vrsvh6i927mm6rm1ld5sxah3h5sr3bsjm90vb8lxrxfya"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libsoup" ,libsoup)))
+ (synopsis "GObject-based API over @acronym{SSDP, Simple Service Discovery
+Protocol} for GNOME")
+ (description "This package provides a library to handle resource discovery
+and announcement over @acronym{SSDP, Simple Service Discovery Protocol} and
+a debugging tool, @command{gssdp-device-sniffer}.")
+ (home-page "https://gitlab.gnome.org/GNOME/gssdp")
+ (license license:lgpl2.0+)))
+
(define-public libmediaart
(package
(name "libmediaart")