summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:50 +0100
committerGuix Patches Tester <>2020-01-13 07:50:06 +0000
commitb7639cb9f0859be718e9484f325a826253a3730f (patch)
treef56c5ae9f7da6399c612d7b871f1edc6877e2f7d
parentabb6bb324df1983204c4a4f7cdb01f8ffabfb5d3 (diff)
downloadpatches-b7639cb9f0859be718e9484f325a826253a3730f.tar
patches-b7639cb9f0859be718e9484f325a826253a3730f.tar.gz
gnu: Add python-forbiddenfruit
* gnu/packages/python-xyz.scm (python-forbiddenfruit): New variable
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e581e8ec18..8dcc4fe76d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17123,3 +17123,32 @@ that take parsers as their arguments and return them as result values.")
"Python Assertion Helpers inspired by Shouldly")
(license license:isc)))
+(define-public python-forbiddenfruit
+ (package
+ (name "python-forbiddenfruit")
+ (version "0.1.3")
+ (source
+ (origin
+ ;; Source tarball on PyPi lacks Makefile that builds and runs tests
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clarete/forbiddenfruit")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fp2xvdqpi910j9r3q68x38phpxbm700gjdi2m2j5gs91xdnyyh2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "make" "SKIP_DEPS=1"))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-coverage" ,python-coverage)))
+ (home-page
+ "https://github.com/clarete/forbiddenfruit")
+ (synopsis "Patch python built-in objects")
+ (description "This project allows Python code to extend built-in types.")
+ (license (list license:gpl3+ license:expat))))