summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-12 23:08:44 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-12 23:08:44 +0100
commitb5f013929a776b6ae0611a1eeb19aa158412c65f (patch)
treecb43297e1b9c413bf465f4d0789c5994edcbb1de
parenta65cc579b95be6f1db35e7e69bfda1544f3419ab (diff)
downloadpatches-b5f013929a776b6ae0611a1eeb19aa158412c65f.tar
patches-b5f013929a776b6ae0611a1eeb19aa158412c65f.tar.gz
gnu: Add gnome-user-share.
* gnu/packages/gnome.scm (gnome-user-share): New variable.
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ea70c9ac75..a8e89f51fe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -417,6 +417,46 @@ tour of all gnome components and allows the user to set them up.")
(home-page "https://gitlab.gnome.org/GNOME/gnome-initial-setup")
(license license:gpl2)))
+(define-public gnome-user-share
+ (package
+ (name "gnome-user-share")
+ (version "3.33.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0lf790pyamdyj7180ils8vizjl8brxcg7jsm1iavfp9ay4wa8mz7"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ `("-Dsystemd=false"
+ ;; Enable nautilus extension for file sharing.
+ "-Dnautilus_extension=true")))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("glib" ,glib)
+ ("gnome-bluetooth" ,gnome-bluetooth)
+ ("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libnotify" ,libnotify)
+ ("nautilus" ,nautilus))) ; For nautilus extension.
+ (synopsis "File sharing for GNOME desktop")
+ (description "GNOME User Share is a small package that binds together
+various free software projects to bring easy to use user-level file
+sharing to the masses.")
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-user-share")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")