summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:49 +0100
committerGuix Patches Tester <>2020-01-13 07:50:05 +0000
commitabb6bb324df1983204c4a4f7cdb01f8ffabfb5d3 (patch)
treee727e5821e418feb73956984ce163eadbcc88384
parent291a85b29b166200dcc5bd2ff69af5e13ab68877 (diff)
downloadpatches-abb6bb324df1983204c4a4f7cdb01f8ffabfb5d3.tar
patches-abb6bb324df1983204c4a4f7cdb01f8ffabfb5d3.tar.gz
gnu: Add python-shouldbe
* gnu/packages/python-xyz.scm (python-shouldbe): New variable
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c308796e7..e581e8ec18 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17098,3 +17098,28 @@ scripts to load entry points more quickly.")
functional combinators. Parser combinators are just higher-order functions
that take parsers as their arguments and return them as result values.")
(license license:expat)))
+
+(define-public python-shouldbe
+ (package
+ (name "python-shouldbe")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shouldbe" version))
+ (sha256
+ (base32
+ "16zbvjxf71dl4yfbgcr6idyim3mdrfvix1dv8b95p0s9z07372pj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-forbiddenfruit" ,python-forbiddenfruit)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/directxman12/should_be")
+ (synopsis
+ "Python Assertion Helpers inspired by Shouldly")
+ (description
+ "Python Assertion Helpers inspired by Shouldly")
+ (license license:isc)))
+