summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:51 +0100
committerGuix Patches Tester <>2020-01-13 07:50:06 +0000
commit89072c4e877f7c549a35b07fdbc3253a5bfc1930 (patch)
tree8a3708918c675c7346b9dfba3781fafaae4083c6
parentb7639cb9f0859be718e9484f325a826253a3730f (diff)
downloadpatches-89072c4e877f7c549a35b07fdbc3253a5bfc1930.tar
patches-89072c4e877f7c549a35b07fdbc3253a5bfc1930.tar.gz
gnu: Add python-k5test
* gnu/packages/python-xyz.scm (python-k5test): New variable
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8dcc4fe76d..b2736318d7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
@@ -17152,3 +17153,41 @@ that take parsers as their arguments and return them as result values.")
(synopsis "Patch python built-in objects")
(description "This project allows Python code to extend built-in types.")
(license (list license:gpl3+ license:expat))))
+
+(define-public python-k5test
+ (package
+ (name "python-k5test")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "k5test" version))
+ (sha256
+ (base32
+ "1lqp3jgfngyhaxjgj3n230hn90wsylwilh120yjf62h7b1s02mh8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ;; `which`, `kadmin.local` binaries called inside library
+ ("which" ,which)
+ ("mit-krb5" ,mit-krb5)))
+ (native-inputs `(("mit-krb5" ,mit-krb5)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* _
+ (substitute* "k5test/realm.py"
+ (("'kadmin_local'") "'kadmin.local'")))))))
+ (home-page
+ "https://github.com/pythongssapi/k5test")
+ (synopsis
+ "Library for testing Python applications in self-contained Kerberos 5
+environments")
+ (description
+ "k5test is a library for setting up self-contained Kerberos 5
+environments, and running Python unit tests inside those environments.
+It is based on the file of the same name found alongside the MIT Kerberos 5
+unit tests.")
+ (license license:isc)))
+