summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-13 08:46:52 +0100
committerGuix Patches Tester <>2020-01-13 07:50:07 +0000
commit453ecba98042c290cab67ca5b2805694d7e59498 (patch)
tree00d83f3988a2927265ffc254dd4213b46fcee222
parent89072c4e877f7c549a35b07fdbc3253a5bfc1930 (diff)
downloadpatches-453ecba98042c290cab67ca5b2805694d7e59498.tar
patches-453ecba98042c290cab67ca5b2805694d7e59498.tar.gz
gnu: Add python-gssapi
* gnu/packages/python-xyz.scm (python-gssapi): New variable
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2736318d7..7deb162705 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17191,3 +17191,33 @@ It is based on the file of the same name found alongside the MIT Kerberos 5
unit tests.")
(license license:isc)))
+(define-public python-gssapi
+ (package
+ (name "python-gssapi")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gssapi" version))
+ (sha256
+ (base32
+ "1gymg4asvwrz7y13qpwp2s5g8qwq179d72gkj09q6bfcgs82l5wr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-decorator" ,python-decorator)
+ ("python-six" ,python-six)))
+ (inputs
+ `(("mit-krb5" ,mit-krb5)))
+ ;; for tests
+ (native-inputs
+ `(("python-shouldbe" ,python-shouldbe)
+ ("python-parameterized" ,python-parameterized)
+ ("python-k5test" ,python-k5test)
+ ("python-nose" ,python-nose)))
+ (home-page
+ "https://github.com/pythongssapi/python-gssapi")
+ (synopsis "Python GSSAPI Wrapper")
+ (description "Python-GSSAPI provides both low-level and high level wrappers
+around the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it
+should also be useable with other GSSAPI mechanisms.")
+ (license license:isc)))