summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-01-12 22:23:49 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-12 23:40:33 +0100
commit299e15c16e4a50ebd8fa3be9962d655895dca4ce (patch)
tree4ebb448d6e3ba735f4a8155ee17957db3ab090c9
parent4bfc925ae573b2cf68cc28e5007729d34ebb27eb (diff)
downloadpatches-299e15c16e4a50ebd8fa3be9962d655895dca4ce.tar
patches-299e15c16e4a50ebd8fa3be9962d655895dca4ce.tar.gz
gnu: Add julius.
* gnu/packages/games.scm (julius): New variable.
-rw-r--r--gnu/packages/games.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1f6064d082..6d5d8e7ad0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
@@ -739,6 +739,34 @@ automata. The following features are available:
@end enumerate")
(license license:gpl2+)))
+(define-public julius
+ (package
+ (name "julius")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bvschaik/julius.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kgyzfjii4dhpy2h05977alwdmxyxb4jxznnrhlgb21m0ybncmvp"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-mixer" ,sdl2-mixer)))
+ (home-page "https://github.com/bvschaik/julius")
+ (synopsis "Re-implementation of Caesar III game engine")
+ (description
+ "Engine for Caesar III, a city-building real-time strategy game.
+Julius includes some UI enhancements while preserving the logic (including
+bugs) of the original game, so that saved games are compatible. This package
+does not include game data.")
+ (license (list license:agpl3
+ license:expat ; ext/dirent
+ license:zlib)))) ; ext/tinyfiledialogs
+
(define-public meandmyshadow
(package
(name "meandmyshadow")