summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-12 21:39:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-12 22:23:27 +0100
commit20eb3b7e747b25f5d2c85167158353cc74e09e41 (patch)
treee360fdc3ba30f7ee3c9e459c66c159d0550b40b7
parentf9ea47a978882541063dd0d77c138be881ce0688 (diff)
downloadpatches-20eb3b7e747b25f5d2c85167158353cc74e09e41.tar
patches-20eb3b7e747b25f5d2c85167158353cc74e09e41.tar.gz
gnu: spice: Fix test failure on armhf-linux.
* gnu/packages/patches/spice-fix-test-armhf.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/spice.scm (spice)[source](patches): New field.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/spice-fix-test-armhf.patch19
-rw-r--r--gnu/packages/spice.scm1
3 files changed, 21 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9dd67ddd5c..cb46ee7880 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1382,6 +1382,7 @@ dist_patch_DATA = \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
+ %D%/packages/patches/spice-fix-test-armhf.patch \
%D%/packages/patches/steghide-fixes.patch \
%D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
%D%/packages/patches/superlu-dist-awpm-grid.patch \
diff --git a/gnu/packages/patches/spice-fix-test-armhf.patch b/gnu/packages/patches/spice-fix-test-armhf.patch
new file mode 100644
index 0000000000..5c51bd6ede
--- /dev/null
+++ b/gnu/packages/patches/spice-fix-test-armhf.patch
@@ -0,0 +1,19 @@
+Fix test failure on armhf and ppc64el:
+https://gitlab.freedesktop.org/spice/spice-server/issues/31
+
+Taken from upstream:
+https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
+
+diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
+index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
+--- a/server/tests/test-qxl-parsing.c
++++ b/server/tests/test-qxl-parsing.c
+@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
+ RedMemSlotInfo mem_info;
+ init_meminfo(&mem_info);
+
+- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
++ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
+ }
+
+ static void test_memslot_invalid_addresses(void)
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index edc6135fbd..a57e0151ca 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -197,6 +197,7 @@ which allows users to view a desktop computing environment.")
(uri (string-append
"https://www.spice-space.org/download/releases/"
"spice-server/spice-" version ".tar.bz2"))
+ (patches (search-patches "spice-fix-test-armhf.patch"))
(sha256
(base32
"19r999py9v9c7md2bb8ysj809ag1hh6djl1ik8jcgx065s4b60xj"))))