summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-12 11:40:22 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-12 14:49:27 +0100
commit8dc2af3ba541141d8320e860cec31090d5b69dc0 (patch)
tree98713f3db87858e62468689c065c692aa11ae3b4
parent6b8f7c397aa9c8b3f078153b1b6a90db3bb0b79e (diff)
downloadpatches-8dc2af3ba541141d8320e860cec31090d5b69dc0.tar
patches-8dc2af3ba541141d8320e860cec31090d5b69dc0.tar.gz
gnu: sbcl-trivial-backtrace: Fix build reproducibility.
* gnu/packages/lisp.scm (sbcl-trivial-backtrace)[arguments]: Add 'delete-test-results' phase.
-rw-r--r--gnu/packages/lisp-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8d9cf53526..cffd43cfc7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3376,6 +3376,19 @@ client and server.")
(build-system asdf-build-system/sbcl)
(inputs
`(("sbcl-lift" ,sbcl-lift)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'check 'delete-test-results
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((test-results (string-append (assoc-ref outputs "out")
+ "/share/common-lisp/"
+ (%lisp-type) "-source"
+ "/trivial-backtrace"
+ "/test-results")))
+ (when (file-exists? test-results)
+ (delete-file-recursively test-results)))
+ #t)))))
(home-page "https://common-lisp.net/project/trivial-backtrace/")
(synopsis "Portable simple API to work with backtraces in Common Lisp")
(description