summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-08 06:57:53 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-08 10:21:45 +0300
commit73656471a403039b4d28de08e0c0b61326c4dea7 (patch)
treee08151d4d458f2807fec52c2f15edf421a9b4f6c
parentce0ca7625e10328061e9d4819592d4084ff92b86 (diff)
downloadpatches-73656471a403039b4d28de08e0c0b61326c4dea7.tar
patches-73656471a403039b4d28de08e0c0b61326c4dea7.tar.gz
gnu: neofetch: Update to 6.1.0-1.501d6b7.
Fix Guix ascii not shown. * gnu/packages/admin.scm (neofetch): Update to 6.1.0-1.501d6b7.
-rw-r--r--gnu/packages/admin.scm50
1 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f0581bbea5..371fcc7ec3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2904,34 +2905,35 @@ tool for remote execution and deployment.")
(license license:bsd-2)))
(define-public neofetch
- (package
- (name "neofetch")
- (version "6.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dylanaraps/neofetch")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "022xzn9jk18k2f4b6011d8jk5nbl84i3mw3inlz4q52p2hvk8fch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; there are no tests
- #:make-flags
- (list (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
- (home-page "https://github.com/dylanaraps/neofetch")
- (synopsis "System information script")
- (description "Neofetch is a command-line system information tool written in
+ (let ((commit "501d6b7594296d9eac8943140f8581daf555873d"))
+ (package
+ (name "neofetch")
+ (version (git-version "6.1.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dylanaraps/neofetch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h5md9jimyc6z4d7w66j27hn8qghzyxgpkh5h9dclzxpp5cs8whb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:make-flags
+ (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://github.com/dylanaraps/neofetch")
+ (synopsis "System information script")
+ (description "Neofetch is a command-line system information tool written in
Bash. Neofetch displays information about your system next to an image, your OS
logo, or any ASCII file of your choice. The main purpose of Neofetch is to be
used in screenshots to show other users what operating system or distribution
you are running, what theme or icon set you are using, etc.")
- (license license:expat)))
+ (license license:expat))))
(define-public screenfetch
(package