summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-07 18:31:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:42 +0100
commitb6c2805c0b6d9d237c52f9e0cc779fb7af548b93 (patch)
tree9a51f60b89cd22e1cb2ef96d44dbcfabcf48ff5c
parent43d4c2298143631ada19539314c99775c18747e7 (diff)
downloadpatches-b6c2805c0b6d9d237c52f9e0cc779fb7af548b93.tar
patches-b6c2805c0b6d9d237c52f9e0cc779fb7af548b93.tar.gz
gnu: hyperrogue: Fix FTBFS with GCC7.
* gnu/packages/games.scm (hyperrogue)[arguments]: Remove redundant #:make-flags. Preserve original CPATH when adding SDL path.
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5d7c89a880..f46da6cff4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3635,7 +3635,8 @@ throwing people around in pseudo-randomly generated buildings.")
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl-union")
+ (string-append (getenv "CPATH") ":"
+ (assoc-ref inputs "sdl-union")
"/include/SDL"))))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)