summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-01-09 09:14:31 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2020-01-09 15:36:08 +0100
commite05471a1a9a8d147e11a8e729bccca4b30b9bfbc (patch)
treebe0ecdea7a89e60df6f732fa9f5999ed55d7f943
parent1a7d58dc628a2ebf1ab1db693a4946aa2b98bd2f (diff)
downloadpatches-e05471a1a9a8d147e11a8e729bccca4b30b9bfbc.tar
patches-e05471a1a9a8d147e11a8e729bccca4b30b9bfbc.tar.gz
gnu: Add gnome-online-miners.
* gnu/packages/gnome.scm (gnome-online-miners): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 195705e765..e034fc0c86 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -247,6 +247,41 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-online-miners
+ (package
+ (name "gnome-online-miners")
+ (version "3.30.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0pjamwwzn5wqgihyss357dyl2q70r0bngnqmwsqawchx5f9aja9c"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("gobject-introspection" ,gobject-introspection)
+ ("grilo" ,grilo)
+ ("libgdata" ,libgdata)
+ ("libgfbgraph" ,gfbgraph)
+ ("libzapojit" ,libzapojit)
+ ("rest" ,rest)
+ ("tracker" ,tracker)))
+ (synopsis "Web Crawlers for GNOME")
+ (description "GNOME Online Miners provides a set of crawlers that
+go through your online content and index them locally in Tracker.
+It has miners for Facebook, Flickr, Google, ownCloud and SkyDrive.")
+ (home-page "https://wiki.gnome.org/Projects/GnomeOnlineMiners")
+ (license license:gpl2)))
+
(define-public gnome-menus
(package
(name "gnome-menus")