summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:35 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:38:29 +0100
commitbadc1c630f6406b060cdcfbc7b846ba7c5e3c612 (patch)
treebdf823bb38d57c2998e09ffac36dd05a68ac5b46
parentc6f008d6266a443344ce89e222c9534b2056d806 (diff)
downloadpatches-badc1c630f6406b060cdcfbc7b846ba7c5e3c612.tar
patches-badc1c630f6406b060cdcfbc7b846ba7c5e3c612.tar.gz
gnu: Add python-cachy.
* gnu/packages/python-xyz.scm (python-cachy): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c518783bb0..0927601027 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10729,6 +10729,34 @@ smaller. Small integers are encoded into a single byte, and typical short
strings require only one extra byte in addition to the strings themselves.")
(license license:asl2.0)))
+(define-public python-cachy
+ (package
+ (name "python-cachy")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cachy" version))
+ (sha256
+ (base32
+ "0v6mjyhgx6j7ya20bk69cr3gdzdkdf6psay0h090rscclgji65dp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-fakeredis" ,python-fakeredis)
+ ("python-flexmock" ,python-flexmock)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-memcached" ,python-memcached)
+ ("python-msgpack-python" ,python-msgpack-python)
+ ("python-redis" ,python-redis)))
+ (home-page "https://github.com/sdispater/cachy")
+ (synopsis "Simple yet effective caching library")
+ (description
+ "Cachy provides a simple yet effective caching library. A simple but
+powerful API: thread-safety; decorator syntax; support for memcached, redis,
+database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
+ (license license:expat)))
+
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")