summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 19:32:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:07 +0200
commitb8f6e2f82a733759017269170e7b8813f04a9425 (patch)
treec5c46cb3c63b290e75fc4b15aca31c67b4a6062c
parentdc66835226858236c12c498cc9de0e98c8c86e18 (diff)
downloadpatches-b8f6e2f82a733759017269170e7b8813f04a9425.tar
patches-b8f6e2f82a733759017269170e7b8813f04a9425.tar.gz
gnu: Add r-ordinal.
* gnu/packages/cran.scm (r-ordinal): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f64b48da5f..590d2c90d3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2005,6 +2005,33 @@ algorithm. The interface of @code{ucminf} is designed for easy interchange
with the package @code{optim}.")
(license license:gpl2+)))
+(define-public r-ordinal
+ (package
+ (name "r-ordinal")
+ (version "2018.8-25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ordinal" version))
+ (sha256
+ (base32
+ "03cv9hcrw8j3lhamzhz8sk2p3ns4cw9z41x49h301k2b3pajv43h"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-matrix" ,r-matrix)
+ ("r-numderiv" ,r-numderiv)
+ ("r-ucminf" ,r-ucminf)))
+ (home-page "https://github.com/runehaubo/ordinal")
+ (synopsis "Regression models for ordinal data")
+ (description
+ "This package provides an implementation of cumulative link (mixed)
+models also known as ordered regression models, proportional odds models,
+proportional hazards models for grouped survival times and ordered models.
+Estimation is via maximum likelihood and mixed models are fitted with the
+Laplace approximation and adaptive Gauss-Hermite quadrature.")
+ (license license:gpl2+)))
+
(define-public r-jomo
(package
(name "r-jomo")