summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-06-09 02:57:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-06-15 17:03:14 +0200
commit9e99b1b41ba007124861092ad4bd0995e25abd2a (patch)
tree23fefeacafc4dd917052f7e4d93850debdae9c81
parent99952c538b5931bca814b47d840ce83e41e46f4e (diff)
downloadpatches-9e99b1b41ba007124861092ad4bd0995e25abd2a.tar
patches-9e99b1b41ba007124861092ad4bd0995e25abd2a.tar.gz
gnu: Add texlive-generic-dehyph-exptl.
* gnu/packages/tex.scm (texlive-generic-dehyph-exptl): New variable.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9e05eee516..7e4d29be53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -256,6 +256,41 @@ set up and one for initializing XeTeX character classes as has been carried
out to date by @code{unicode-letters.tex}. ")
(license license:lppl1.3c+)))
+(define-public texlive-generic-dehyph-exptl
+ (package
+ (name "texlive-generic-dehyph-exptl")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/generic/dehyph-exptl"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "1l9wgv99qq0ysvlxqpj4g8bl0dywbzra4g8m2kmpg2fb0i0hczap"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/generic/dehyph-exptl")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://projekte.dante.de/Trennmuster/WebHome")
+ (synopsis "Hyphenation patterns for German")
+ (description "The package provides experimental hyphenation patterns for
+the German language, covering both traditional and reformed orthography. The
+patterns can be used with packages Babel and hyphsubst from the Oberdiek
+bundle.")
+ ;; Hyphenation patterns are under the Expat license; documentation is
+ ;; under LPPL.
+ (license (list license:expat license:lppl))))
+
(define texlive-texmf
(package
(name "texlive-texmf")