summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-10 11:28:59 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-12 00:19:09 +0100
commit9b65dea806431ec8491184c3e89bab457042a68b (patch)
tree6edb08c37e29114618ae70f6ef062807018a8c5c
parent6e36f1cabdac4f7e306002fe56e84eadd1dfdbbe (diff)
downloadpatches-9b65dea806431ec8491184c3e89bab457042a68b.tar
patches-9b65dea806431ec8491184c3e89bab457042a68b.tar.gz
gnu: Use the two-element 'define-deprecated' form where applicable.
* gnu/packages/guile.scm (guile-json): Use the two-element 'define-deprecated' form. * gnu/packages/kde.scm (kdevplatform): Likewise. * gnu/packages/mpi.scm (hwloc-2.0): Likewise. * gnu/packages/qt.scm (qt): Likewise.
-rw-r--r--gnu/packages/guile.scm6
-rw-r--r--gnu/packages/kde.scm4
-rw-r--r--gnu/packages/mpi.scm3
-rw-r--r--gnu/packages/qt.scm4
4 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 30a72ec62c..bcb8ff1a56 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
@@ -460,9 +460,7 @@ specification. These are the main features:
;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
;; 'guile-json-3'.
-(define-deprecated guile-json
- guile-json-1
- guile-json-1)
+(define-deprecated guile-json guile-json-1)
(export guile-json)
(define-public guile2.0-json
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 1620cb1b2e..bb5c25014e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -297,7 +297,7 @@ for some KDevelop language plugins (Ruby, PHP, CSS...).")
(license license:lgpl2.0+)))
;; kdevplatform was merged into kdevelop as of 5.2.x
-(define-deprecated kdevplatform kdevelop kdevelop)
+(define-deprecated kdevplatform kdevelop)
(define-public krita
(package
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 55641d8fa1..00e0d12eab 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -159,8 +159,7 @@ bind processes, and much more.")
"-1"))
#t))))))))
-(define-deprecated hwloc-2.0 'hwloc-2
- hwloc-2)
+(define-deprecated hwloc-2.0 hwloc-2)
(define-public hwloc
;; The latest stable series of hwloc.
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7c2cb0af21..514577678e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2015, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
@@ -588,7 +588,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
;; qt used to refer to the monolithic Qt 5.x package
-(define-deprecated qt qtbase qtbase)
+(define-deprecated qt qtbase)
(define-public qtsvg