summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-11 23:34:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-11 23:49:11 +0200
commit83feb3d005d3c098838596fbc0a3e1de1b62b131 (patch)
tree66fa5080a9c9eb60209157cfab3f11d7774ee5b3
parent1e158ba15653a06601b6443740007e6ce8917aea (diff)
downloadpatches-83feb3d005d3c098838596fbc0a3e1de1b62b131.tar
patches-83feb3d005d3c098838596fbc0a3e1de1b62b131.tar.gz
gnu: Add python-jeepney.
* gnu/packages/python-crypto.scm (python-jeepney): New variable.
-rw-r--r--gnu/packages/python-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 43a0d95ddc..b95a4f2056 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1135,3 +1135,26 @@ storing and retrieving sensitive information in your programs.")
package provides a tool to securely sign firmware images for booting by
MCUboot.")
(license license:expat)))
+
+(define-public python-jeepney
+ (package
+ (name "python-jeepney")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jeepney" version))
+ (sha256
+ (base32
+ "1fz9lb5fl831sijg2j0sbki698j2z6awbblas7mz3gp9jz2xi9hb"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-testpath" ,python-testpath)
+ ("python-tornado" ,python-tornado)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://gitlab.com/takluyver/jeepney")
+ (synopsis "Low-level, pure Python DBus protocol wrapper")
+ (description
+ "This is a low-level, pure Python DBus protocol client. It has an
+I/O-free core, and integration modules for different event loops.")
+ (license license:expat)))