summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-01-10 17:23:31 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-12 00:19:09 +0100
commit79154f0a09ad748839f88120ddd61a0e1e147b5e (patch)
tree8dce4af2e1421890a97493996f312d847727cca7
parent0de28f9ef94634f536118acc736a01a8c5ee239d (diff)
downloadpatches-79154f0a09ad748839f88120ddd61a0e1e147b5e.tar
patches-79154f0a09ad748839f88120ddd61a0e1e147b5e.tar.gz
gnu: cmake@3.15.5: Honor 'SSL_CERT_DIR' and 'SSL_CERT_FILE'.
* gnu/packages/cmake.scm (cmake-3.15.5)[native-search-paths]: New field.
-rw-r--r--gnu/packages/cmake.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index de49f52f2b..2d2827ffee 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -228,7 +228,21 @@ and workspaces that can be used in the compiler environment of your choice.")
"1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))
(patches
(append (search-patches "cmake-curl-certificates.patch")
- (origin-patches (package-source cmake))))))))
+ (origin-patches (package-source cmake))))))
+
+ (native-search-paths
+ ;; "cmake-curl-certificates.patch" changes CMake to honor 'SSL_CERT_DIR'
+ ;; and 'SSL_CERT_FILE', hence these search path entries.
+ (append (list (search-path-specification
+ (variable "SSL_CERT_DIR")
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs")))
+ (search-path-specification
+ (variable "SSL_CERT_FILE")
+ (file-type 'regular)
+ (separator #f) ;single entry
+ (files '("etc/ssl/certs/ca-certificates.crt"))))
+ (package-native-search-paths cmake)))))
;; This was cmake@3.15.1 plus "cmake-curl-certificates.patch".
(define-deprecated cmake/fixed cmake-3.15.5)