summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 13:42:29 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:07:46 +0200
commit6bba8ecf7b9a087d405d30373bd18a5e524f4918 (patch)
tree1d81f5e9d6473dc63008b0d47f1a3e6ea661b27f
parentf22c038799a9c83816ce6e19bf2220d4022ba642 (diff)
downloadpatches-6bba8ecf7b9a087d405d30373bd18a5e524f4918.tar
patches-6bba8ecf7b9a087d405d30373bd18a5e524f4918.tar.gz
gnu: Add ruby-rdoc.
* gnu/packages/ruby.scm (ruby-rdoc): New variable.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8321dda4cc..cd88ea921c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5208,3 +5208,24 @@ your application.")
(sha256
(base32
"1h39zqqxp3k4qk49ajpx0jps1vmvxgkh43mqkb6znk583bl0fv71"))))))
+
+(define-public ruby-rdoc
+ (package
+ (name "ruby-rdoc")
+ (version "6.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rdoc" version))
+ (sha256
+ (base32
+ "0anv42cqcdc6g4n386mrva7mgav5i0c2ry3yzvzzc6z6hymkmcr7"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (home-page "https://ruby.github.io/rdoc/")
+ (synopsis "HTML and command-line documentation utility")
+ (description "RDoc produces HTML and command-line documentation for Ruby
+projects. RDoc includes the +rdoc+ and +ri+ tools for generating and displaying
+documentation from the command-line.")
+ (license license:gpl2+)))