summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-11 23:35:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-11 23:49:11 +0200
commit4ee1ea76facb11bc2f022312bd4858fb642b3f4e (patch)
tree16a60cc77988e42db7c4234b8bb0bb5b601ba302
parent83feb3d005d3c098838596fbc0a3e1de1b62b131 (diff)
downloadpatches-4ee1ea76facb11bc2f022312bd4858fb642b3f4e.tar
patches-4ee1ea76facb11bc2f022312bd4858fb642b3f4e.tar.gz
gnu: Add python-secretstorage.
* gnu/packages/python-crypto.scm (python-secretstorage): New variable.
-rw-r--r--gnu/packages/python-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index b95a4f2056..8d677efe62 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1136,6 +1136,34 @@ package provides a tool to securely sign firmware images for booting by
MCUboot.")
(license license:expat)))
+(define-public python-secretstorage
+ (package
+ (name "python-secretstorage")
+ (version "3.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "SecretStorage" version))
+ (sha256
+ (base32
+ "1xmzr0j3066s220bss4nkgqbiwb5k4kkp2rkpqlqwjb5kfc8mnhm"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; Tests require a running dbus service.
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-jeepney" ,python-jeepney)))
+ (home-page "https://github.com/mitya57/secretstorage")
+ (synopsis "Python bindings to FreeDesktop.org Secret Service API")
+ (description
+ "@code{python-secretstorage} provides a way for securely storing passwords
+and other secrets. It uses D-Bus Secret Service API that is supported by GNOME
+Keyring (since version 2.30) and KSecretsService. SecretStorage supports most
+of the functions provided by Secret Service, including creating and deleting
+items and collections, editing items, locking and unlocking collections
+(asynchronous unlocking is also supported).")
+ (license license:bsd-3)))
+
(define-public python-jeepney
(package
(name "python-jeepney")