summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-11 19:11:44 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-12 00:19:10 +0100
commit489703898380ab1a0db86f82c4861a33bf97b5fd (patch)
tree0581ce0321e4dd9a9fb80d46f11d3b5831a3d826
parent58236d301c5266ba22d420149de72e9d135fc387 (diff)
downloadpatches-489703898380ab1a0db86f82c4861a33bf97b5fd.tar
patches-489703898380ab1a0db86f82c4861a33bf97b5fd.tar.gz
gnu: entr: Fix references to external programs.
* gnu/packages/entr.scm (entr)[arguments](remove-fhs-file-names): Use 'which' instead of relying on the runtime PATH. Patch /bin/sh too. [inputs]: Add NCURSES. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/entr.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/entr.scm b/gnu/packages/entr.scm
index d0111452df..cacb5ab7f5 100644
--- a/gnu/packages/entr.scm
+++ b/gnu/packages/entr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,6 +21,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages entr)
+ #:use-module (gnu packages ncurses)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -52,11 +54,13 @@
(invoke "./configure"))))
(add-before 'build 'remove-fhs-file-names
(lambda _
- ;; Use the tools available in $PATH.
(substitute* "entr.c"
- (("/bin/cat") "cat")
- (("/usr/bin/clear") "clear"))
+ (("/bin/sh") (which "sh"))
+ (("/bin/cat") (which "cat"))
+ (("/usr/bin/clear") (which "clear")))
#t)))))
+ ;; ncurses provides the `clear' binary
+ (inputs `(("ncurses" ,ncurses)))
(home-page "http://entrproject.org/")
(synopsis "Run arbitrary commands when files change")
(description