summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-14 22:11:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 13:05:22 +0100
commit476f7fceb7be08d9302e06d808a5d226a3dfd2a2 (patch)
treec8962a6bb206b549fccc92929c5d96a1ff7f07d1
parent9c45beb4cc2972c1368fdbf21ee4fe467848f3a4 (diff)
downloadpatches-476f7fceb7be08d9302e06d808a5d226a3dfd2a2.tar
patches-476f7fceb7be08d9302e06d808a5d226a3dfd2a2.tar.gz
gnu: texlive-union: Wrap programs weakly.
* gnu/packages/tex.scm (texlive-union)[arguments]: Wrap programs with TEXMFCNF and TEXMF so that environment variables take precedence.
-rw-r--r--gnu/packages/tex.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2876438cf9..a9eed006bb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1879,8 +1879,8 @@ standard LaTeX packages."
"/bin"))
(for-each
(cut wrap-program <>
- `("TEXMFCNF" ":" = (,(dirname texmf.cnf)))
- `("TEXMF" ":" = (,(string-append out "/share/texmf-dist"))))
+ `("TEXMFCNF" ":" suffix (,(dirname texmf.cnf)))
+ `("TEXMF" ":" suffix (,(string-append out "/share/texmf-dist"))))
(find-files (string-append out "/bin") ".*"))
#t))))
(inputs