summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-01-02 01:43:21 -0600
committerLudovic Courtès <ludo@gnu.org>2020-01-09 23:33:04 +0100
commit3da1e6e9edbef14cdd8a989ad68fa5d445a5c83e (patch)
tree8410941bd52bf6a649671bb5f1354beb185237b8
parentef09cb866c379abae54432e8d91f0d14cbd1309b (diff)
downloadpatches-3da1e6e9edbef14cdd8a989ad68fa5d445a5c83e.tar
patches-3da1e6e9edbef14cdd8a989ad68fa5d445a5c83e.tar.gz
gnu: Add emacs-monky.
* gnu/packages/emacs-xyz.scm (emacs-monky): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4b5008cf0d..558f315d45 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7938,6 +7938,32 @@ pasting into and from @code{tmux} paste buffers.")
to search.")
(license license:gpl3+))))
+(define-public emacs-monky
+ (package
+ (name "emacs-monky")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ananthakumaran/monky.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1fgn7al4zwz2k5wb5dy3byqg9lsrjk9fra341mxh5ma2pfwxjgps"))))
+ (build-system emacs-build-system)
+ (home-page "https://ananthakumaran.in/monky/index.html")
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "test/monky-unit-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (synopsis "Interactive interface for the Mercurial version control system")
+ (description
+ "Monky provides an Emacs interface for Mercurial (Hg). Using Monky, you
+can selectively commit files, view the diffs, and other things.")
+ (license license:gpl3+)))
+
(define-public emacs-monroe
(package
(name "emacs-monroe")